Setting up a VPS IOTA Full Node from scratch!


Author
Message
Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
ionta - 8 Dec 2017
Hi, I get the following error when I try to run the visual interface. I installed the node following these instructions first: http://iota.partners/ -
Then I found your post and tried running the visual interface

Serving IOTA peer dashboard at http://94.130.229.186:8888
events.js:160
  throw er; // Unhandled 'error' event
  ^

Error: listen EADDRNOTAVAIL 94.130.229.186:8888
  at Object.exports._errnoException (util.js:1020:11)
  at exports._exceptionWithHostPort (util.js:1043:20)
  at Server._listen2 (net.js:1249:19)
  at listen (net.js:1298:10)
  at net.js:1408:9
  at _combinedTickCallback (internal/process/next_tick.js:83:11)
  at process._tickCallback (internal/process/next_tick.js:104:9)
  at Module.runMain (module.js:606:11)
  at run (bootstrap_node.js:383:7)
  at startup (bootstrap_node.js:149:9)

Ionta, be sure to have a reachable API endpoint at  94.130.229.186:14265. 
If you are in Linux, try doing this from your computer using your internet (not boxed in your VPS) 
curl http://localhost:14265 \
-X POST \
-H 'Content-Type: application/json' \
-H 'X-IOTA-API-Version: 1' \
-d '{"command": "getNodeInfo"}
'

This should return data from your node. Let me know the outcome.
Scott J
Scott J
Forum Admin (21K reputation)
Group: Administrators
Posts: 53, Visits: 946
Great guide, Carpincho. 

Thank you for including the Peer Manager part - that is a life saver! 
ManniTiger
M
Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)Attached to Tangle (616 reputation)
Group: Forum Members
Posts: 20, Visits: 0
Hello,

i am absolut linux noob. Sad

at the end with nohub.....

when i close the session with putty, server stops means http://173.212.193.00:8888 stop connect / not available.

And what happens when the server restart?

Thx fpr your help


Rachdingue
R
Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)
Group: Forum Members
Posts: 2, Visits: 4
Muchas gracias Carpincho!

Will you keep updating this guide with some new features? I've seen improvements to peer managers and all that.

Thanks

Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
Scott J - 11 Dec 2017
Great guide, Carpincho. 

Thank you for including the Peer Manager part - that is a life saver! 

One thing I should add (and I will as soon as I can dedicate some time to redo the complete guide and repost it because I cannot edit it anymore) is that you can install the iota-pm on your local machine as well. In fact it's better because you wont end up with a public access point that anybody can use.
So you install iota-pm in the VPS and in your local computer and then you run it from home by using

nohup iota-pm -i http://173.212.193.00:14265 -p 127.0.0.1:12000 


That would give you access on your local browser at http://127.0.0.1:12000
Edited 2 Years Ago by Carpincho
Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
Rachdingue - 13 Dec 2017
Muchas gracias Carpincho!

Will you keep updating this guide with some new features? I've seen improvements to peer managers and all that.

Thanks

I can no longer edit this Post which is a pitty because this kind of guides need constant upgrades.
Will continue upgrading in some other place.
captainbronzebeard
c
Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)Attaching to Tangle (48 reputation)
Group: Forum Members
Posts: 2, Visits: 0
Mega noob question here, I have a full node running and is syncing. I still see that transactions and tips are going through but what I dont understand is what are tips? How do they work and how are they claimed? (if thats how it works?) 

Thank you

CBB
Rachdingue
R
Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)Attaching to Tangle (23 reputation)
Group: Forum Members
Posts: 2, Visits: 4
After a while my node seems to freeze or stops working. Although in the peer manager seems to be alright, the milestone doesn't refresh. I have to restart the node and then the milestone starts to refresh to the coordinator milestone

Why is that?
NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.
Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


Edited 2 Years Ago by Carpincho
NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini
Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
NickM - 19 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini

Try just running the node with the port param to see if that works
java -jar iri-1.4.1.4.jar -p 14265



NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini

Try just running the node with the port param to see if that works
java -jar iri-1.4.1.4.jar -p 14265



Yes the node will run without any errors when using -p 14265
NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
NickM - 20 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini

Try just running the node with the port param to see if that works
java -jar iri-1.4.1.4.jar -p 14265



Yes the node will run without any errors when using -p 14265

also runs if i do this: java -jar iri-1.4.1.4.jar -c iri.ini -p 1426
mixim
mixim
Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)Attaching to Tangle (81 reputation)
Group: Forum Members
Posts: 6, Visits: 8
lindbergio - 10 Dec 2017
I would suggest running the applications using systemd service files instead of nohup. This will make it possible to start the applications on boot and makes for a better handling of the applications.

Here is the systemd service file I use for iri:
[Unit]
Description=Iri
After=network.target

[Service]
Type=simple
WorkingDirectory=/opt/iri/target
ExecStart=/usr/bin/java -jar iri-1.4.1.2.jar -c iri.ini
Restart=on-failure
RestartSec=10s

[Install]
WantedBy=multi-user.target

Here is the systemd service file I use for iota-pm (collected from https://github.com/akashgoswami/ipm/blob/master/systemd/iota-pm.service):
[Unit]
Description=IOTA Peer Manager
After=network.target

[Service]
#User=iota
#Group=iota
Type=simple
ExecStart=/usr/bin/iota-pm -i http://127.0.0.1:14265 -p 127.0.0.1:8888
Restart=on-failure
RestartSec=10s

[Install]
WantedBy=multi-user.target

Please come with suggestions to improve the systemd service files as I'm no expert.

Change the API endpoint and the local server ip and port to reflect your setup.

Hi,
thx for the service files, i used that, but i was aware that my CPU load raised up to
200% (VPS, 2 Cores), so i added the following lines in the [Service]-Section:

CPUAccounting=true
CPUQuota=75%

to limit the CPU-load, cause i use the server for other services also. For every CPU-Core
you have 100%, so you have to decide how much percentage you may give to your IOTA-node.
In my case it is 75 / 200 % = 37,5 %

Cheers, MiXiM

Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
NickM - 20 Dec 2017
NickM - 20 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini

Try just running the node with the port param to see if that works
java -jar iri-1.4.1.4.jar -p 14265



Yes the node will run without any errors when using -p 14265

also runs if i do this: java -jar iri-1.4.1.4.jar -c iri.ini -p 1426

This is strange but I guess you can run it by passing -c and -p despite the fact that PORT is included in the iri.ini file.
Could you get it to work?
Let me know!
Carpincho
Carpincho
Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)Attached to Tangle (968 reputation)
Group: Moderators
Posts: 33, Visits: 122
mixim - 20 Dec 2017
lindbergio - 10 Dec 2017
I would suggest running the applications using systemd service files instead of nohup. This will make it possible to start the applications on boot and makes for a better handling of the applications.

Here is the systemd service file I use for iri:
[Unit]
Description=Iri
After=network.target

[Service]
Type=simple
WorkingDirectory=/opt/iri/target
ExecStart=/usr/bin/java -jar iri-1.4.1.2.jar -c iri.ini
Restart=on-failure
RestartSec=10s

[Install]
WantedBy=multi-user.target

Here is the systemd service file I use for iota-pm (collected from https://github.com/akashgoswami/ipm/blob/master/systemd/iota-pm.service):
[Unit]
Description=IOTA Peer Manager
After=network.target

[Service]
#User=iota
#Group=iota
Type=simple
ExecStart=/usr/bin/iota-pm -i http://127.0.0.1:14265 -p 127.0.0.1:8888
Restart=on-failure
RestartSec=10s

[Install]
WantedBy=multi-user.target

Please come with suggestions to improve the systemd service files as I'm no expert.

Change the API endpoint and the local server ip and port to reflect your setup.

Hi,
thx for the service files, i used that, but i was aware that my CPU load raised up to
200% (VPS, 2 Cores), so i added the following lines in the [Service]-Section:

CPUAccounting=true
CPUQuota=75%

to limit the CPU-load, cause i use the server for other services also. For every CPU-Core
you have 100%, so you have to decide how much percentage you may give to your IOTA-node.
In my case it is 75 / 200 % = 37,5 %

Cheers, MiXiM

I am also having killer loads on my CPUs.
Whill try adding those lines!

NickM
N
Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)Attaching to Tangle (33 reputation)
Group: Forum Members
Posts: 7, Visits: 9
Carpincho - 21 Dec 2017
NickM - 20 Dec 2017
NickM - 20 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 19 Dec 2017
NickM - 19 Dec 2017
Carpincho - 18 Dec 2017
NickM - 18 Dec 2017
HI need help getting this error :
iota@iota-PowerEdge-1950:/opt/iri/target$ java -jar iri-1.4.1.2.jar -c iri.ini12/18 17:47:13.379 [main] ERROR com.iota.iri.IRI - Invalid arguments list. Provide at least the PORT in iota.ini or with -p option
12/18 17:47:13.381 [main] INFO com.iota.iri.IRI - Usage: java -jar IRI-1.4.1.2.jar [{-n,--neighbors} '<list of neighbors>'] [{-p,--port} 14600] [{-c,--config} 'config-file-name'] [{-u,--udp-receiver-port} 14600] [{-t,--tcp-receiver-port} 15600] [{-d,--debug} false] [{--testnet} false][{--remote} false][{--remote-auth} string][{--remote-limit-api} string]
iota@iota-PowerEdge-1950:/opt/iri/targe
iri file
[IRI]
port = 14265
udp_receiver_port = 14600
tcp_receiver_port = 15600
neighbors = udp://neighbor-1:14600 udp://neighbor-2:14600
ixi_dir = ixi
Headless = false
Debug = true
db_path = mainnetdb
api_host = 192.168.1.125

Hi NIckM
Are you using a config file with the name iri.ini12/18?
Maybe the problem is with the "/" and that's why your are getting that error.
Try renaming the file to something like iri.ini-12-18 and try with (mv iri.ini12/18 iri.ini-12-18) and then:
java -jar iri-1.4.1.2.jar -c iri.ini-12-18

no the file name is iri.ini the 12/18 was when it was created but is not in the file name.

My bad!
It's kind of a weird error since the argument you are passing is fine.
Let's try this: update to latest IRI released a few days ago and try again
Go to your target directory and do this:
wget https://github.com/iotaledger/iri/releases/download/v1.4.1.4/iri-1.4.1.4.jar

That will download the already compiled version of the 1.4.1.4 IRI
Then try again with
java -jar iri-1.4.1.4.jar -c iri.ini

Please be sure that your config file is actually named iri.ini !!!
Let me know the outcome


thanks but no joy. The error message "Provide at least the PORT in iota.ini or with -p option " makes think that there is a ini file in the folder iota. I did double check the file name is iri.ini

Try just running the node with the port param to see if that works
java -jar iri-1.4.1.4.jar -p 14265



Yes the node will run without any errors when using -p 14265

also runs if i do this: java -jar iri-1.4.1.4.jar -c iri.ini -p 1426

This is strange but I guess you can run it by passing -c and -p despite the fact that PORT is included in the iri.ini file.
Could you get it to work?
Let me know!

Yes it runs passing the -c and -p on the sane line but not able to reach it from my other linux system, curl returns Host not found.  Iota is running so on to the next problem.
thanks for your help.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Login

Explore
Messages
Mentions
Search